Vedhæftet fil til PHP - afsendelse af en vedhæftet fil med PHP

Kan jquery 1.12.4, der bruges på et websted, påvirke placeringen af ​​søgemaskiner (især for Google)? Flere fora og websteder har diskuteret sårbarheder med denne særlige version af jquery.

Ref: https://security.stackexchange.com/questions/205864/is-there-a-way-to-exploit-jquery-1-12-4-vulnerability

  • 1 Hvorfor ikke opgradere til den nyeste version?
  • Biblioteksreferencen var en del af et plugin, jeg bruger. Jeg arbejder dog på at teste og opgradere til det nyeste.

Nej. Så vidt jeg ved, kontrollerer Google ikke JavaScript-biblioteksversioner, da det ville være en meget rodet og upræcis forretning. Plus, jQuery-sårbarheden er kun i en bestemt del af biblioteket, så hvis den del af biblioteket ikke bruges, kommer det ikke i spil alligevel.

Hvis dit websted bliver brugt aktivt til svindel eller distribuering af malware, kan det naturligvis påvirke din rang, men brug af et bibliotek med en mellemsikkerheds-CVE bør ikke.

  • Af nysgerrighed tjekkede jeg netop fyrens revisionsrapport for StackExchange. StackExchange bruger også jquery 1.12.4. Interessant :) men betryggende. Hvis ikke et StackOverflow-websted, så hvem skal rangere.

arbejdet for dig: Charles Robertson | Ønsker du at kontakte os?